. . .

Infrastructure Requirements

These are the hardware requirements to install ApiOmat . Kindly refer to the Scalability, Redundancy and Setup planning page to find the right setup type for your preferences.

Hardware-Sizing

 

Lite

Basic

Enterprise

App-Server

Dualcore, 8GB RAM, 300GB HDD

Quadcore, 8GB RAM, 500GB HDD Raid 1

Hexacore, 16GB RAM, 500GB HDD Raid 1

DB-Server

-

Dualcore, 16GB RAM, 1TB HDD Raid 5 oder 10

Quadcore, >32GB RAM, >1TB HDD Raid 10

# Server

1

2 Appserver, 3 DB Server (Replication)

3+ Appserver, 3-x DB Server (Replication or Sharding)

OS

Windows

Linux Distribution

  • Windows Server 2008 R2 / 2012 / 2012 R2

  • Redhat Enterprise 6.8 / 7 / 7.1 / 7.2 / 7.3 / 7.4/ 7.5

  • CentOS 6.8 / 7 / 7.1 / 7.2 / 7.3 / 7.4 / 7.5

  • Oracle Linux 7.2

  • Suse Linux 12

  • Ubuntu 12.04 / 14.04 / 16.04 /18.04 LTS

  • Debian 7 / 8 / 9

Firewall settings

Access to the following URIs is needed for proper license handling from within the server. Plase adjust firewall and/or proxy settings in your data center:

Packages components and dependencies

Java

Tomcat

Apache Webserver

PHP

PEAR

MongoDB

Version 8

Version 8

latest from package manager

Version 5.3 - 5.6 / 7.0 - 7.1

latest from package manager

3.2.x / 3.4.x / 3.6.x/ 4.0.x